summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorStijn Buys <ingar@osirion.org>2012-06-05 18:07:28 +0000
committerStijn Buys <ingar@osirion.org>2012-06-05 18:07:28 +0000
commit42cb020233b6635f2d06b7f7b533a0ee4f85f4fa (patch)
tree0c3b13cb9b715cbf2ad5a705c8f1066dcac78a75 /src/Makefile.am
Initial import,
added automake project files, application framework, initial sudoku widget
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..a67c97d
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,19 @@
+bin_PROGRAMS = sudosolve
+
+# You have two .cpp files you wrote, editor.cpp and another.cpp
+# Remember to include the name of the resource file with the .cpp extension.
+sudosolve_SOURCES = \
+ main.cc \
+ mainwindow.cc \
+ sudoku.cc
+
+# You have one .h file, it's called editor.h. Therefore, here I list
+# its mocced name, moc_editor.cpp.
+nodist_sudosolve_SOURCES = \
+ moc_mainwindow.cc \
+ moc_sudoku.cc
+
+# This rule lets GNU make create any moc_*.cpp from the equivalent *.h
+moc_%.cc: %.h
+ moc $< -o $@
+